Jump to content


Photo

Mobile X Desktop themes


  • Please log in to reply
13 replies to this topic

#1 saudoso

saudoso
  • Member

  • 4,672 posts
  • Joined: March 04

Posted 27 January 2014 - 14:36

Here's what happens:

 

My iPhone will always render the forum with the mobile theme. While I stick to the iPhone, the desktop will always render the desktop theme.

 

If I access the forum from the iPod Touch, it uses the desktop theme. I switch it to the mobile theme. Now the desktop will use the mobile theme.

 

I switch back to desktop theme on the desktop and now the iPod Touch will also use the desktop theme while the iPhone will sitck with the mobile one.

 

The iPod Touch & Desktop will fight for the themes while the iPhone just sits the and watches the fight.

 

Any ideas?



Advertisement

#2 Grayson

Grayson
  • AUTOSPORT digital product manager

  • 1,379 posts
  • Joined: July 08

Posted 27 January 2014 - 15:24

Not only is the forum software supposed to be able to tell the difference between the mobile and the desktop, it's also supposed to be doing something smart with your account so that it will remember which theme you like to use across devices (so that if you like to view the mobile theme on your desktop, it will show this theme no matter which computer you use to log in). It sounds like it's wrongly recognising the iPod touch as a desktop computer rather than a mobile device. I'll try to find out whether this is something that we can modify or whether it's baked into the software.

 

Are you using the basic built in version of Safari? And are you using the latest version of the iOS?



#3 saudoso

saudoso
  • Member

  • 4,672 posts
  • Joined: March 04

Posted 27 January 2014 - 15:37

IOS 7.0.4, vanilla safari



#4 Buttoneer

Buttoneer
  • RC Forum Admin

  • 16,824 posts
  • Joined: May 04

Posted 27 January 2014 - 15:53

On my desktop I use Atlas Orange theme.  Using iPhone and iPad the browswer defaults to mobile version, which is great.

 

However in iPad I sometimes switch to full version because that's far better for moderating, and when I do that it defaults to Red theme.

 

When I next browse to the forum on my desktop, I am presented with the Autosport red theme.  So I switch to Atlas Orange.

 

Then I turn on the iPad and switch it to full version etc etc.



#5 Timstr11

Timstr11
  • Member

  • 7,765 posts
  • Joined: May 02

Posted 08 February 2014 - 10:25

I also constantly have to switch between Mobile and Desktop and vice versa, when I have previously viewed the mobile version on my phone (Android Chrome browser) or the Desktop version on my 15.6" screen Laptop.

Quite annoying actually.



#6 saudoso

saudoso
  • Member

  • 4,672 posts
  • Joined: March 04

Posted 16 February 2014 - 12:28

Any news on this?



#7 Timstr11

Timstr11
  • Member

  • 7,765 posts
  • Joined: May 02

Posted 26 February 2014 - 18:17

This problem seems to have disappeared. At least for me it has. Is that due to a fix?

Anyway, glad the problem is no longer there.



#8 saudoso

saudoso
  • Member

  • 4,672 posts
  • Joined: March 04

Posted 10 March 2014 - 19:42

Now it's broken everywhere, even the iPhone that would live peacefuly with the desktop is paing ping-pong with the styles.



#9 saudoso

saudoso
  • Member

  • 4,672 posts
  • Joined: March 04

Posted 14 March 2014 - 19:00

If someone is following here: Just now it's back working with the iPhone. iPod still broken.



#10 saudoso

saudoso
  • Member

  • 4,672 posts
  • Joined: March 04

Posted 30 April 2014 - 12:55

Is this forgotten?

 

Well, new finding: If I'm not logged in the iPod touch goes to the mobile theme. When I log in it switches to the desktop theme.

 

iPhone works fine under mobile all the time.



#11 Grayson

Grayson
  • AUTOSPORT digital product manager

  • 1,379 posts
  • Joined: July 08

Posted 30 April 2014 - 13:23

The main problem (how the system remembers your mobile/desktop preferences across separate devices) hasn't been forgotten. We're going to need a solution for this for the mobile version of the main site (which runs separately to the forums) so hopefully we will be able to apply that solution to the forums as well.



#12 saudoso

saudoso
  • Member

  • 4,672 posts
  • Joined: March 04

Posted 28 June 2014 - 13:01

Adding insult to injury now the desktop version that will run on the iPod Touch started to misbehave on the gadget. Shaky scrolling and 10 taps to get a link to open, failing to open even when the tapped link highlights.

 

It's unusable.


Edited by saudoso, 28 June 2014 - 13:01.


#13 panzani

panzani
  • Member

  • 18,691 posts
  • Joined: September 03

Posted 01 July 2014 - 17:25

How can I 'like' a post using mobile skin?

#14 saudoso

saudoso
  • Member

  • 4,672 posts
  • Joined: March 04

Posted 01 July 2014 - 19:28

There's a tick mark there, it will do the trick.