Jump to content


Photo

Int. Motor Racing Research Center, Watkins Glen


  • Please log in to reply
5 replies to this topic

#1 Rob Semmeling

Rob Semmeling
  • Member

  • 837 posts
  • Joined: December 02

Posted 21 January 2007 - 14:29

Although their website - http://www.racingarchives.org - invites people to "contact us" and "write to us", I have not received a reply to an e-mail sent two weeks ago.

This is in fact the second time I have written to the centre, and the second time I have not received an answer. Surely a simple inquiry shouldn't be too much trouble to reply to?

Anyone with a familiar experience?

Advertisement

#2 Terry O'Neil

Terry O'Neil
  • Member

  • 81 posts
  • Joined: November 01

Posted 21 January 2007 - 14:48

I am in constant contact with the Research Centre and have never experienced any undue delays in a response from them.
Try mark@racingarchives.org and your e-mail will get through to Mark Steigerwald.
Terry

#3 HDonaldCapps

HDonaldCapps
  • Member

  • 2,482 posts
  • Joined: April 05

Posted 21 January 2007 - 16:07

Rob, or anyone else here, if there is ever a problem such as you encountered, please let me know. And, as Terry suggests, anything sent to Mark should get through to him. I have been dealing with them going on seven or so years now and have rarely had a problem.

#4 David M. Kane

David M. Kane
  • Member

  • 5,399 posts
  • Joined: December 00

Posted 21 January 2007 - 17:32

Me too. I talked to Mark just last week.

#5 Rob Semmeling

Rob Semmeling
  • Member

  • 837 posts
  • Joined: December 02

Posted 21 January 2007 - 18:37

Thanks all, will try again via Mark. :up:

#6 Allen Brown

Allen Brown
  • Member

  • 4,885 posts
  • Joined: December 00

Posted 22 January 2007 - 13:44

I agree with all the above. Mark is a lovely man and is most helpful.

Allen